Краш при запуске игры

  • К сожалению был утрачен доступ ко всем вложениям на форуме, просьба отдерактировать свои темы/аватарки и загрузить их снова. Приносим свои извинения.

Mzuha

Игрок
12 Июн 2020
9
0
11
Launcher Agent
GravitLauncher (fork sashok724's Launcher) Client Launcher v5.2.2-1 stable
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
2022.03.04 13:10:20 [WARN] JLine2 isn't in classpath, using std
2022.03.04 13:10:20 [INFO] Reading EC keypair
2022.03.04 13:10:21 [INFO] Using Sessions
2022.03.04 13:10:21 [INFO] 25.321-b07
2022.03.04 13:10:21 [INFO] DirWatcher /Users/vovabilodon/minecraft/GamePoint/updates/assets-min-1.16.5
2022.03.04 13:10:21 [INFO] DirWatcher /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock
2022.03.04 13:10:22 [ERROR] java.nio.file.NoSuchFileException: native/macos/x86_64/libdiscord_game_sdk_jni.dylib
at pro.gravit.utils.helper.IOHelper.getResourceURL(Unknown Source)
at pro.gravit.launcher.gaMepOIntGJzIS.GaMEpOiNtPbPqC(Unknown Source)
at pro.gravit.launcher.gaMepOIntGJzIS.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gamEPoint5YEVd.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gAmepOInTslbaP.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOintaZVJe.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOInTHPoa2.main(Unknown Source)

[13:10:22] [main/INFO]: ModLauncher running: args [--username, Mzuha, --uuid, 3fe71441acb711ea85fee06995e56a32, --accessToken, ❄❄❄❄❄❄❄❄, --userType, mojang, --userProperties, {"skinURL":["http://dev.gamepoint.su/players/skins/Mzuha.png"],"skinDigest":["15fc1eb25f9747da0f3dd5e586c509de2803b0b1654918833df6f54e1cbb892e"]}, --assetIndex, 1.16.5, --version, 1.16.5, --gameDir, /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock, --assetsDir, /Users/vovabilodon/minecraft/GamePoint/updates/assets-min-1.16.5, --resourcePackDir, /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/resourcepacks, --versionType, Launcher v5.2.2, --launchTarget, fmlclient, --fml.forgeVersion, 36.2.27, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20210115.111550]
[13:10:22] [main/INFO]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version 1.8.0_321 by Oracle Corporation
[13:10:22] [main/INFO]: OptiFineTransformationService.onLoad
[13:10:22] [main/INFO]: OptiFine ZIP file: /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/mods/OptiFine.jar
[13:10:22] [main/INFO]: Target.PRE_CLASS is available
[13:10:22] [main/INFO]: Added Lets Encrypt root certificates as additional trust
[13:10:22] [main/INFO]: SpongePowered MIXIN Subsystem Version=0.8.4 Source=file:/Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/libraries/forge/mixin-0.8.4.jar Service=ModLauncher Env=CLIENT
[13:10:22] [main/INFO]: OptiFineTransformationService.initialize
[13:10:22] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
[13:10:22] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
[13:10:22] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
2022.03.04 13:10:22 [ERROR] java.lang.ExceptionInInitializerError
at org.lwjgl.glfw.GLFW.nglfwSetErrorCallback(GLFW.java:996)
at org.lwjgl.glfw.GLFW.glfwSetErrorCallback(GLFW.java:1029)
at org.lwjgl.glfw.GLFWErrorCallback.set(GLFWErrorCallback.java:132)
at net.minecraftforge.fml.loading.progress.ClientVisualization.initWindow(ClientVisualization.java:68)
at net.minecraftforge.fml.loading.progress.ClientVisualization.start(ClientVisualization.java:341)
at net.minecraftforge.fml.loading.progress.EarlyProgressVisualization.accept(EarlyProgressVisualization.java:43)
at net.minecraftforge.fml.loading.FMLLoader.setupLaunchHandler(FMLLoader.java:190)
at net.minecraftforge.fml.loading.FMLServiceProvider.initialize(FMLServiceProvider.java:94)
at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:68)
at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$7(TransformationServicesHandler.java:107)
at java.util.HashMap$Values.forEach(HashMap.java:983)
at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:107)
at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:59)
at cpw.mods.modlauncher.Launcher.run(Launcher.java:76)
at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
at java.lang.invoke.MethodHandle.invokeWithArguments(MethodHandle.java:627)
at pro.gravit.launcher.gaMepOInTHPoa2.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOInTHPoa2.main(Unknown Source)
Caused by: java.lang.NullPointerException: A required function is missing: glfwGetMonitorWorkarea
at org.lwjgl.system.APIUtil.requiredFunctionMissing(APIUtil.java:141)
at org.lwjgl.system.APIUtil.apiGetFunctionAddress(APIUtil.java:134)
at org.lwjgl.glfw.GLFW$Functions.<clinit>(GLFW.java:693)
... 18 more

2022.03.04 13:10:22 [INFO] WebSocket client disconnect
Process exit code 0
 


NiKKinG

Администратор
Команда проекта
Форумчанин
Администратор
22 Янв 2021
223
34
38
Попробуйте установить java 311, а эту версию удалите
 


Big_Energy

root
Команда проекта
Гл. Администратор
14 Сен 2018
4,758
173
198
1646401067758.png

Включите опции для мака
 


Mzuha

Игрок
12 Июн 2020
9
0
11
Они и так включены
 

Вложения

  • Screenshot 2022-03-04 at 15.40.15.png
    Screenshot 2022-03-04 at 15.40.15.png
    992.1 KB · Просмотры: 2




Big_Energy

root
Команда проекта
Гл. Администратор
14 Сен 2018
4,758
173
198
Драйвер видеокарты обновите, в таком случае
 


Mzuha

Игрок
12 Июн 2020
9
0
11
Попробуйте установить java 311, а эту версию удалите
Launcher Agent
GravitLauncher (fork sashok724's Launcher) Client Launcher v5.2.2-1 stable
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
2022.03.04 15:45:33 [WARN] JLine2 isn't in classpath, using std
2022.03.04 15:45:33 [INFO] Reading EC keypair
2022.03.04 15:45:33 [INFO] Using Sessions
2022.03.04 15:45:33 [INFO] 25.311-b11
2022.03.04 15:45:34 [INFO] DirWatcher /Users/vovabilodon/minecraft/GamePoint/updates/assets-min-1.16.5
2022.03.04 15:45:34 [INFO] DirWatcher /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock
2022.03.04 15:45:34 [ERROR] java.nio.file.NoSuchFileException: native/macos/x86_64/libdiscord_game_sdk_jni.dylib
at pro.gravit.utils.helper.IOHelper.getResourceURL(Unknown Source)
at pro.gravit.launcher.gaMepOIntGJzIS.GaMEpOiNtPbPqC(Unknown Source)
at pro.gravit.launcher.gaMepOIntGJzIS.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gamEPoint5YEVd.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gAmepOInTslbaP.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOintaZVJe.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOInTHPoa2.main(Unknown Source)

[15:45:35] [main/INFO]: ModLauncher running: args [--username, Mzuha, --uuid, 3fe71441acb711ea85fee06995e56a32, --accessToken, ❄❄❄❄❄❄❄❄, --userType, mojang, --userProperties, {"skinURL":["http://dev.gamepoint.su/players/skins/Mzuha.png"],"skinDigest":["15fc1eb25f9747da0f3dd5e586c509de2803b0b1654918833df6f54e1cbb892e"]}, --assetIndex, 1.16.5, --version, 1.16.5, --gameDir, /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock, --assetsDir, /Users/vovabilodon/minecraft/GamePoint/updates/assets-min-1.16.5, --resourcePackDir, /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/resourcepacks, --versionType, Launcher v5.2.2, --launchTarget, fmlclient, --fml.forgeVersion, 36.2.27, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20210115.111550]
[15:45:35] [main/INFO]: ModLauncher 8.1.3+8.1.3+main-8.1.x.c94d18ec starting: java version 1.8.0_311 by Oracle Corporation
[15:45:35] [main/INFO]: OptiFineTransformationService.onLoad
[15:45:35] [main/INFO]: OptiFine ZIP file: /Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/mods/OptiFine.jar
[15:45:35] [main/INFO]: Target.PRE_CLASS is available
[15:45:35] [main/INFO]: Added Lets Encrypt root certificates as additional trust
[15:45:35] [main/INFO]: SpongePowered MIXIN Subsystem Version=0.8.4 Source=file:/Users/vovabilodon/minecraft/GamePoint/updates/OneBlock/libraries/forge/mixin-0.8.4.jar Service=ModLauncher Env=CLIENT
[15:45:35] [main/INFO]: OptiFineTransformationService.initialize
[15:45:35] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
[15:45:35] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
[15:45:35] [main/INFO]: [org.lwjgl.system.Library:checkHash:469]: [LWJGL] [ERROR] Incompatible Java and native library versions detected.
Possible reasons:
a) -Djava.library.path is set to a folder containing shared libraries of an older LWJGL version.
b) The classpath contains jar files of an older LWJGL version.
Possible solutions:
a) Make sure to not set -Djava.library.path (it is not needed for developing with LWJGL 3) or make
sure the folder it points to contains the shared libraries of the correct LWJGL version.
b) Check the classpath and make sure to only have jar files of the same LWJGL version in it.
2022.03.04 15:45:35 [ERROR] java.lang.ExceptionInInitializerError
at org.lwjgl.glfw.GLFW.nglfwSetErrorCallback(GLFW.java:996)
at org.lwjgl.glfw.GLFW.glfwSetErrorCallback(GLFW.java:1029)
at org.lwjgl.glfw.GLFWErrorCallback.set(GLFWErrorCallback.java:132)
at net.minecraftforge.fml.loading.progress.ClientVisualization.initWindow(ClientVisualization.java:68)
at net.minecraftforge.fml.loading.progress.ClientVisualization.start(ClientVisualization.java:341)
at net.minecraftforge.fml.loading.progress.EarlyProgressVisualization.accept(EarlyProgressVisualization.java:43)
at net.minecraftforge.fml.loading.FMLLoader.setupLaunchHandler(FMLLoader.java:190)
at net.minecraftforge.fml.loading.FMLServiceProvider.initialize(FMLServiceProvider.java:94)
at cpw.mods.modlauncher.TransformationServiceDecorator.onInitialize(TransformationServiceDecorator.java:68)
at cpw.mods.modlauncher.TransformationServicesHandler.lambda$initialiseTransformationServices$7(TransformationServicesHandler.java:107)
at java.util.HashMap$Values.forEach(HashMap.java:983)
at cpw.mods.modlauncher.TransformationServicesHandler.initialiseTransformationServices(TransformationServicesHandler.java:107)
at cpw.mods.modlauncher.TransformationServicesHandler.initializeTransformationServices(TransformationServicesHandler.java:59)
at cpw.mods.modlauncher.Launcher.run(Launcher.java:76)
at cpw.mods.modlauncher.Launcher.main(Launcher.java:66)
at java.lang.invoke.MethodHandle.invokeWithArguments(MethodHandle.java:627)
at pro.gravit.launcher.gaMepOInTHPoa2.gAmEPOInT2miuH(Unknown Source)
at pro.gravit.launcher.gaMepOInTHPoa2.main(Unknown Source)
Caused by: java.lang.NullPointerException: A required function is missing: glfwGetMonitorWorkarea
at org.lwjgl.system.APIUtil.requiredFunctionMissing(APIUtil.java:141)
at org.lwjgl.system.APIUtil.apiGetFunctionAddress(APIUtil.java:134)
at org.lwjgl.glfw.GLFW$Functions.<clinit>(GLFW.java:693)
... 18 more

2022.03.04 15:45:35 [INFO] WebSocket client disconnect
Process exit code 0